Pseudocódigo Método burbuja 1


La Ordenación de burbuja (Bubble Sort en inglés) es un sencillo algoritmo de ordenamiento. Funciona revisando cada elemento de la lista que va a ser ordenada con el siguiente, intercambiándolos de posición si están en el orden equivocado. Es necesario revisar varias veces toda la lista hasta que no se necesiten más intercambios, lo cual significa que la lista está ordenada. Este algoritmo obtiene su nombre de la forma con la que suben por la lista los elementos durante los intercambios, como si fueran pequeñas “burbujas”. También es conocido como el método del intercambio directo. Dado que solo usa comparaciones para operar elementos, se lo considera un algoritmo de comparación, siendo el más sencillo de implementar.

Proceso burbuja1
    //(a(0), a(1), a(2), … a(n-1))
    Definir i, j, n, a, aux Como Entero;
    n<-10;
    Dimension a[n];
    j<-0;
    i<-0;
    Para j<-1 Hasta n Hacer
        leer a[j];
    FinPara
    Para i<-1 Hasta n-1 Hacer
        Para j<-1 Hasta n-i Hacer
            Si a[j]>a[j+1] Entonces
                aux<-a[j];
                a[j]<-a[j+1];
                a[j+1]<-aux;
            FinSi
        FinPara
    FinPara
    Escribir ‘Ahora ordenado’;
    Para j<-1 Hasta n Hacer
        Escribir  a[j];
    FinPara
FinProceso


Dejar un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

Una idea sobre “Pseudocódigo Método burbuja